The Australian Government coat of Arms

Communities of practice

Communities of practice

Pancake error pancake only works with npm3 or later

I am using Node 12.8.1 and npm 6.10.2, however when I try to install say npm install --save @gov.au/card, I get 'ERROR Pancake only works with npm3 or later.

It is an existing site that was using pancake version 1.2.3, so I updated pancake to v 1.4.1 but still get the error when I try to do an npm install.

Has anyone else encountered this?

Hi @TB80,

Welcome to the forums. Could you please share your project package.json file?

Thanks,

Raj

Thanks @sukhraj.ghuman package below:

{
“name”: “***”,
“version”: “1.0.0”,
“description”: “***”,
“engines”: {
“npm”: “>=3.0.0”
},
“scripts”: {
“pancake”: “./node_modules/.bin/pancake”,
“test”: “echo “Error: no test specified” && exit 0”
},
“author”: “***”,
“devDependencies”: {
@gov.au/pancake”: “^1.4.1”,
“babel-core”: “^6.26.3”,
“babel-eslint”: “^7.1.1”,
“babel-plugin-external-helpers”: “^6.22.0”,
“babel-preset-env”: “^1.6.0”,
“babel-preset-es2015”: “^6.24.1”,
“babel-register”: “^6.26.0”,
“breakpoint-sass”: “^2”,
“browser-sync”: “^2.24.7”,
“del”: “^2”,
“eslint”: “^3.19.0”,
“eslint-config-airbnb”: “^14.0.0”,
“eslint-plugin-import”: “^2.7.0”,
“eslint-plugin-jsx-a11y”: “^3.0.2”,
“eslint-plugin-react”: “^6.9.0”,
“eyeglass”: “^1”,
“eyeglass-inline-svg”: “^0”,
“gulp”: “^4.0”,
“gulp-autoprefixer”: “^3”,
“gulp-babel”: “^7.0.0”,
“gulp-cached”: “^1.1.1”,
“gulp-clean-css”: “^3”,
“gulp-dependents”: “^1.2.3”,
“gulp-eslint”: “^3”,
“gulp-rename”: “^1”,
“gulp-replace”: “^0.5”,
“gulp-rollup-each”: “^2.0.0”,
“gulp-sass”: “^3”,
“gulp-sass-glob”: “^1”,
“gulp-sass-lint”: “^1”,
“gulp-size”: “^2”,
“gulp-sourcemaps”: “^1”,
“gulp-uglify”: “^2.0.0”,
“js-yaml”: “^3”,
“kss”: “3.0.0-beta.18”,
“kss-offscreen-twig”: “^2.0.0-alpha.9”,
“latest”: “^0.2.0”,
“merge-stream”: “^1.0.1”,
“node-sass”: “^4.12.0”,
“rollup-plugin-babel”: “^3.0.2”,
“rollup-plugin-commonjs”: “^8.2.6”,
“rollup-plugin-node-resolve”: “^3.0.0”,
“sass-lint”: “^1”,
“support-for”: “^1”
},
“dependencies”: {
@gov.au/accordion”: “latest”,
@gov.au/animate”: “latest”,
@gov.au/body”: “latest”,
@gov.au/breadcrumbs”: “latest”,
@gov.au/buttons”: “latest”,
@gov.au/callout”: “latest”,
@gov.au/control-input”: “latest”,
@gov.au/core”: “latest”,
@gov.au/cta-link”: “latest”,
@gov.au/direction-links”: “latest”,
@gov.au/footer”: “latest”,
@gov.au/grid-12”: “latest”,
@gov.au/header”: “latest”,
@gov.au/headings”: “latest”,
@gov.au/inpage-nav”: “latest”,
@gov.au/keyword-list”: “latest”,
@gov.au/link-list”: “latest”,
@gov.au/pancake-sass”: “^1.2.0”,
@gov.au/responsive-media”: “latest”,
@gov.au/select”: “latest”,
@gov.au/skip-link”: “latest”,
@gov.au/tags”: “latest”,
@gov.au/text-inputs”: “latest”,
“babel”: “^6.23.0”,
“yarn”: “^1.9.4”
},
“pancake”: {
“auto-save”: false,
“plugins”: true,
“ignore”: [],
“css”: {
“minified”: true,
“modules”: false,
“browsers”: [
“last 2 versions”,
“ie 8”,
“ie 9”,
“ie 10”
],
“location”: “css/uikit”,
“name”: false
},
“sass”: {
“modules”: false,
“location”: “src/_uikit/sass/”,
“name”: “uikit.scss”
},
“js”: {
“minified”: true,
“modules”: true,
“location”: “js/uikit”,
“name”: “uikit.min.js”
},
“json”: {
“enable”: false,
“location”: “pancake/”,
“name”: “pancake”,
“content”: {
“name”: true,
“version”: true,
“dependencies”: true,
“path”: true,
“settings”: true
}
},
“react”: {
“location”: false
}
},
“browserslist”: [
“last 2 versions”,
“ie 8”,
“ie 9”,
“ie 10”
],
“private”: true
}

Hi,

Could you please try removing the dependency:

“latest”: “^0.2.0”

And see if that makes a difference?

This package hasn’t been updated in 5 years, and has a dependency:

"dependencies": { "npm": "^2.5.1" }

There is also an open ticket for this package, which relates to the issue you are having.

Is this package needed? Is there an alternative package that has similar functionality, but is more well maintained?

I will look into it more from a pancake perspective.